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Blender  
Instructor: Aaron F. Ross  
 

Blender is an all-purpose 3D graphics package that excels in many production contexts. 
It can be applied to any graphics discipline, including but not limited to animation, 
visual effects, motion graphics, games, design visualization, and simulations. This 
course covers the basic techniques of modeling, materials, animation, lighting, and 
rendering. Learn the capabilities and best practices of Blender, efficient workflows, and 
choosing appropriate tools for desired results.  

Topics covered include: 

• General concepts of 3D production
• Project setup and asset management
• User interface
• Object creation and transforms
• Add-on extensions
• Parametric modeling with Modifiers
• Polygon modeling
• Subdivision surface modeling
• Sculpting
• Spline modeling
• Text and graphics
• Materials and mapping
• Physically-based rendering
• UV projection and layout
• Practical, studio, and environment lighting
• Camera operation
• Creating and editing animation keyframes
• Fine-tuning animation with the Graph Editor
• Coordinate systems and object origins
• Scene management with the Outliner
• Hierarchies and Constraints
• Production rendering and basic compositing
• Rendering an animation sequence
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1. Introductions 

a. Instructor background and experience 

b. Learner backgrounds, career / production goals, and desired learning outcomes 

2. Presentation: 3D graphic production concepts 

a. Modeling: construction of objects 

i. Form and structure 

ii. Vector-based 

iii. UV coordinates 

b. Materials 

i. Superficial surface properties, e.g. color, roughness, transparency 

ii. Maps: vary material property across a surface 

c. Lighting 

i. Photometric lighting: real-world light intensities 

ii. Global illumination: light interaction with multiple surfaces 

iii. Lighting paradigms 

(1) Practical / available / diegetic 

(2) Studio / stage / non-diegetic 

(3) Environment / ambient 

d. Layout and camera 

i. Merge and place assets in a primary scene 

ii. Placeholders may stand in while assets are being made 

iii. Environment construction determined by camera angles 

iv. Trickery such as forced perspective and matte paintings 
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e. Animation 

i. Rigging: setup of animation controls 

ii. Keyframing: automatic transitions between manual poses 

iii. Motion capture / performance capture 

iv. Dynamics: physical simulations 

v. Visual effects: non-character animation 

f. Rendering 

i. Project 3D scene to 2D image 

ii. Real-time: viewports, games, simulations 

iii. Non-real-time (offline):  motion pictures, animation 

3. Asset management 

a. Asset types and folders 

b. Embed dependent assets in the scene file: Pack Resources   

4. Interface basics 

a. Edit > Preferences > Interface > Resolution Scale 

b. Edit > Preferences > Save & Load > Save Versions = 0 
Disable automatic saving .blend1 files 

c. Workspace tabs 

d. Menus 

e. Areas 

i. Properties 

ii. Outliner 

5. Viewports 

a. Navigation 

i. Orbit: middle mouse drag 
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ii. Pan (truck/pedestal):  SHIFT + middle mouse drag 

iii. Zoom / Dolly:  CTRL + SHIFT + middle mouse drag 

iv. Edit > Preferences > Navigation 

(1) Orbit & Pan > Orbit Around Selection 

(2) Zoom > Zoom to Mouse Position 

b. Maximize View: CTRL + SPACEBAR 

c. Toolbar: selection and transform tools 
Shortcut: T 

d. Sidebar 
Shortcut: N 

e. Orthographic viewports and Quad View (shortcut: CRTL + ALT + Q) 

f. Gizmos 

i. Disable distracting heads up tools: Navigate 

g. Overlays 

h. Shading modes 

i. Wireframe 
Shortcut: SHIFT + Z 

ii. Solid aka shaded 

(1) Renderer: Workbench 

iii. Material Preview 

(1) Renderer: EEVEE 

iv. Rendered 

(1) Production renderer: Properties > Render tab > Render Engine 

(2) Default is the EEVEE real-time renderer 

6. Units and Grid 

a. Properties > Scene tab > Units 
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i. Unit System 

ii. Unit Scale 

b. Perspective grid spacing: Viewport Overlays > Scale 

7. Snapping 

a. Snap Target 

i. Increment vs. Grid 

b. Affect: Move, Rotate, Scale 

8. Blender Add-on extensions 

a. Edit > Preferences > Add-ons 

i. These are all free 

ii. Also available at extensions.blender.org 

b. blender-addons.org 

c. gumroad.com 

d. blendermarket.com 

e. github.com 

i. WonderMesh parametric primitives 
Non-destructive, reversible mesh property 
https://github.com/WiresoulStudio/Wonder_Mesh 

9. Parametric modeling with Modifiers 

a. Non-destructive, reversible 

b. Modifiers are calculated from top to bottom 

c. Deformer Origin 

i. Default center of deformer operation is the Object Origin aka object pivot 

ii. Add > Empty aka dummy, locator, point helper 

d. Bake a single Modifier:  individual Modifier toolbar > pulldown list > Apply 
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e. Bake all:  Viewport menu > Object > Apply > Visual Geometry to Mesh 
Shortcut: CTRL + A 

10. Polygon mesh basics 

a. Edit Mode 
Shortcut: TAB 

b. Component types: Vertex, Edge, Face 
Shortcuts: 1, 2, 3 on alphabetic keypad 

c. Level of detail vs. fidelity 

d. Smoothing:  shading effect of soft edges, gradient applied across faces 

i. Object > Shade Smooth or Shade Flat 

ii. Object > Shade Auto Smooth  

(1) Same as Add Modifier > Normal > Smooth By Angle 

iii. Edge > Mark Sharp or Clear Sharp 

(1) Confusingly does the same thing, and overrides any existing smoothing 

11. Mesh Edit Mode 

a. Default Blender scheme of colors and highlighting is problematic 

b. Overlays 

i. Disable Faces and Center 

c. Viewport Shading (Workbench) 

i. Wire Color = Object or Random 

(1) Properties > Object > Viewport Display > Color 

ii. Color = Object or Single 

(1) Single reveals an unlabeled color swatch directly below. It looks like a 
gray blank nothingness, but it’s actually a color swatch. 

d. Extrude 

i. Extrude Along Normals 
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ii. Inset 
Shortcut: move cursor OFF the selection, then press I.  
Move mouse to adjust, then click to execute. 

e. Select > More / Less 

f. Dissolve 
Shortcut: CTRL + DELETE 

g. Bevel Modifier 

12. Additional mesh modeling tools 

a. Loop Cut 

i. Click an edge to bisect a face loop 

ii. Adjust Last Operation pop-up > Loop Cut and Slide 

iii. Slide Offset: Factor slider 

iv. Number of Cuts 

b. Disable Adjust Last Operation pop-up during low-level modeling 

i. View > Adjust Last Operation 

ii.  Shortcut to display floating pop-up only when needed: F9 

c. Proportional Editing aka “soft selection” 
Shortcut: O 

i. Size = radius 
Shortcut: mouse wheel 
Only works while a transformation is already in progress! 

ii. But before you do that ... choose Falloff type 
Pie menu shortcut: SHIFT + O 

d. Symmetry 

i. Tool Options > Mirror > X 

(1) Destructive, does not work correctly with Proportional Editing 

ii. Mirror Modifier 

(1) For sanity, first delete one side of the model (polygons in negative X) 
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(2) Clean up display, allow selection of mirrored components: Show On Cage 

(3) Protect the seam from gaps and overlaps: Clipping 

13. Subdivision Surface modeling 

a. Polygon count: Gizmos > Statistics 

b. Iterations / level of detail 

i. Levels Viewport vs. Render 

ii. Levels Viewport shortcut: CTRL + numeral on alphabetic keypad 
Subdivision Modifier will be added if it doesn’t already exist 
Values above 3 are probably excessive and risk overloading CPU and RAM 

iii. Show all edges: disable Optimal Display 

c. Topology  

i. Try to use only quadrilateral polygons 

ii. Try to avoid poles where more than four edges meet at a single vertex 

iii. Conform edge flow to the contours of the shape 

d. Increase curvature without increasing poly count: Edge Crease 

i. Shortcut: SHIFT + E 

ii. Sidebar > Item tab > Mean Crease (average value of selected edges) 

iii. Display: Overlays > Creases 

e. Bake / collapse subdivisions 

i. Destructive / non-reversible 

ii. Save As to a new filename before performing a destructive operation  
E.g. my_fabulous_model_baked.blend 

iii. Object > Apply > Visual Geometry to Mesh 

iv. Save file again 
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14. Sculpt Mode 

a. Brush Asset toolbar: Draw, Grab, Inflate, etc. 

i. Display Settings tab > Names 

ii. Tiny scrollbar on the Brush Asset toolbar 
Shortcut: mouse wheel 

b. Properties > Tool tab > Brush  Settings 

i. Brush Settings also found in Sidebar (N) > Tool tab 

ii. Radius Unit = Scene 

iii. Radius shortcut: press F, move mouse without dragging, click to exit 
or [ ] (square brackets) 

iv. Strength shortcut: press SHIFT + F, move mouse without dragging,  
click to exit 

v. Smooth shortcut: SHIFT + drag 

vi. Direction (Add / Subtract) shortcut: CTRL + drag 

15. Spline Curve modeling  

a. Edit > Preferences > Get Extensions > search > Extra Curve Objects 

b. Poly, Bezier, and NURBS 

i. Poly curves are always linear segments 

ii. Edit Mode > Curve > Set Spline Type 

c. Control vertices 

i. Edit Mode > Control Points > Set Handle Type 
Shortcut: V 

(1) Automatic: smooth curve through point 

(2) Vector: linear segment 

(3) Aligned: linked handles 

(4) Free: unlinked handles 
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d. Curve Pen tool 

i. Create Point: click in viewport 

ii. Extrude Point (extend existing curve): click an endpoint, then click in view 

iii. Close Spline (Cyclic): click first endpoint, then click second endpoint  

iv. Insert Point: CTRL + click on curve 

v. Delete Point: CTRL + click on point 

vi. Lock Handle Angle (adjust length only): click handle, then left ALT + drag 

vii. Link Handles: click handle, then right CTRL + drag 

e. Properties > Data tab > Geometry 

i. Extrude and Offset 

ii. Polygon strands: Bevel = Round 

iii. Thickness: Depth 

iv. Level of detail around circumference of implicit circular path: Resolution 
Number of sub-segments in each 90 degree arc of the implicit circle 

f. Properties > Data tab > Shape 

i. 2D vs. 3D 

ii. Level of detail along length of spline: Resolution Preview U 
Number of interpolated sub-segments within each segment 

g. Sweep along path: Geometry > Bevel = Object 

i. Use eyedropper to select profile curve in viewport 

ii. LOD controlled separately for path and profile curve: Resolution Preview U 

iii. To interpolate sub-segments within a linear segment, it must be a Bezier 
spline with Free handles 

(1) If necessary, add more CVs: Segments > Subdivide 

iv. Clean up geometry 

(1) Position profile curve relative to its Origin 
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(a) Edit Mode > Select > All, then Move/Translate 

(b) or Object Mode > Sidebar (N) > Tool tab > Options > Transform > 
Affect Only > Origins 

(2) Offset path curve to restore to the original shape 

(a) Object Mode > Properties > Data > Geometry > Offset 

(b) or Edit Mode > Select > All, then Curve > Transform > Push/Pull 

16. Text 

a. Viewport Edit Mode 

i. Text characters are edited directly in viewport 

ii. Typeface variant  (Bold, Italic, etc.): viewport Text menu 

b. Properties > Data tab (Text) 

i. Browse for font: Font rollout > Regular > folder icon 

ii. Classic chamfered 3D text: 

(1) Paragraph > Alignment > Horizontal = Center 

(2) Geometry > Extrude = 0.1 m 

(3) Geometry > Bevel = Profile 

(4) Geometry > Bevel > Depth = 0.01 m 

(5) Geometry > Bevel > Resolution = 0 

(6) Add Modifier > Normals > Smooth by Angle 

17. Viewport Shading 

a. Solid/Wireframe: Workbench 

b. Rendered: Cycles 

c. Material Preview: EEVEE 

i. Scene Lights and Scene World 
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18. Shader Editor 

a. Main window > Shading tab 

i. Change World environment 

(1) Add > Texture > Sky Texture 

(2) Connect Color to Background node 

(3) Background Strength = 0.15  

b. Object color vs. material 

i. Properties > Object > Viewport Display > Color 

c. Create material 

d. Building shader trees  

i. Shader Editor Menu > Add nodes 

ii. Right-click > Add 

iii. Drag out from an input port 

e. Properties of selected node: Sidebar 
Shortcut: N 

19. Physically-based materials 

a. Principled BSDF shader 

i. Physically-based rendering “principles” 
Bidirectional Scattering Distribution Function 

ii. Base Color 

iii. Roughness 

iv. Metallic 

v. IOR (Index of Refraction) 

b. Layers of the Principled BSDF shader are available as separate nodes 

i. e.g. Metallic BSDF, Diffuse BSDF, etc. 
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ii. Optimize rendering by using only the needed properties 

iii. Build your own custom shader 

20. Mapping basics 

a. Mappable properties: color, relief, floating point 

b. File maps 

i. 2D images stored in linked external files 

ii. Image Texture nodes 

iii. Asset management 

21. UV Projection 

a. UV coordinates in the shading network 

i. Texture Coordinates node UV output  Mapping node Vector input  
Mapping node Vector output  Image Texture Vector input 

b.  UV coordinates stored in object vertices 

c. Project UVs from Camera 

i. Create Image Texture node and connect to Base Color or Emission Color 

(1) The other, unconnected property should be set to black 

ii. Click New, enter a Name, set Generated Type to Color Grid 

iii. Viewport menu > Add > Camera 

(1) Rename: Camera UV Projection or similar 

(2) Position and rotate in preparation for projection 

(3) Properties > Data (Camera) > Type = Orthographic 

iv. Add Modifier > Edit > UV Project 

(1) Assign Camera: click Object eyedropper, choose Camera in scene 

(2) Adjust Modifier Scale 

(3) Position Camera 
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22. Procedural maps 

a. 2D or 3D patterns generated within the application 

b. Don’t require UV coordinates 

c. Noise Texture node 

23. UV Layout 

a. Boundaries of UV space 

b. Tiling 

c. Unwrapping 

24. Rendering in Cycles 

a. Enable GPU in Edit > Preferences > System > Cycles Render Devices 

i. Choose Optix if possible 

b. Properties > Scene > Scene 

i. Render Engine = Cycles 

ii. Device = GPU Compute 

c. Sampling > Viewport > Max Samples = 128 

d. Sampling > Render > Max Samples = 512 

e. Sampling > Denoise > Use GPU = enabled 
or Denoiser = Optix 

f. Viewport > Shading Mode = Rendered 

i. GPU needs to precompile, be prepared for a long wait the first time 

ii. Pause button at upper right 

g. Properties > Scene > Color Management 

i. Exposure 

ii. View Transform = Standard 

(1) Linear response, no contrast curve applied 
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h. Properties > Output  

i. Format > Resolution = 1280 x 720 

ii. Frame Range > End = 1 

iii. To automatically save the file, we need to render an animation sequence of 
only one frame 

iv. Output 

(1) Browse to /renderoutput folder and enter a filename 
Add a trailing underscore to separate filename from frame number  

(2) Color = RGB 

(a) RGBA would create a PNG with embedded transparency 
Background would be knocked out and could never be recovered 

(3) Compression = 0 

(4) Image Sequence > Overwrite = disabled 

i. Main Menu > Render > Render Animation 

i. Render > Render Image (F12) would not save any file 
We would need to manually save each rendered image  

25.  Camera basics 

a. Toggle view between Camera and User Perspective 

i. Navigation overlay > Camera icon 
Shortcut: numpad 0 

b. Lock Camera to View 

i. First person camera navigation within viewport 

ii. Also known as Enable view navigation within the camera view 

iii. Camera view > Navigation overlay > Lock icon 

iv. Sidebar (N) > View tab > View Lock > Camera to View 

(1) Disabled: 2D zoom 

(2) Enabled: 3D dolly 
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c. Field of view: Focal Length 

i. Sidebar property is only for User Perspective views 

ii. Camera object > Properties > Data tab (Camera) > Lens > Focal Length 

d. Film gate mask: Properties > Data tab (Camera) > Viewport Display > 
Passepartout (type of picture frame, image inside cutout matte)  

e. Aspect ratio: Properties > Output > Format > Resolution 

26. Lighting basics 

a. Point, Sun, Spot, Area 

b. Size matters! Softness of light and shadow is controlled by size of light source 

c. Point 

i. Power 

ii. Size of light sphere: Radius 

d. Use Nodes = enabled 

e. Assign Color to Blackbody 

i. 4800 degrees Kelvin 

ii. Doesn’t currently work in EEVEE 

27. Practical and available lighting 

a. Area 

i. Shape 

ii. Beam Shape > Spread 

(1) Focused / collimated beam 

iii. Office ceiling light fixtures 

(1) Shape = Rectangle 

(2) Size X = 0.54 m 

(3) Size Y = 1.15 m 
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(4) Position XYZ =  -2.575  1.05  3.98 

(5) Power = 60 W 

iv. Instancing: multiple objects share the same data-block 

(1) Change one object, all instances update 

(2) One object in multiple places at the same time 

(3) Viewport menu > Object > Duplicate Linked 

b. Light shapes are not visible to the camera 

i. Perplexing limitation 

ii. Sub-optimal workaround: mesh object with shader Emission 

(1) Very inefficient and slow to render 

(2) No Spread property 

iii. Better workaround: combine Area light with self-illuminated mesh object  

(1) Light Path node > Is Camera Ray output  Mix Shader node Fac input 

(2) Principled BSDF node  Mix Shader node top Shader input 

(3) Emission Shader node  Mix Shader node bottom Shader input 

c. Sun 

i. Also known as distant, directional, or direct light 

ii. Better control with standard pan / tilt rotations 

(1) Sidebar (N) > Transform tab > Rotation = YXZ Euler 

(2) Rotation X = locked 

(3) Transform Orientation = Gimbal 

(4) Z is pan, Y is tilt 

iii. Size of sun disc: Angle 
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28. Studio lighting 

a. Spot 

i. Cone Angle: Spot Size 

ii. Size of light disc: Radius 

iii. Center falloff: Blend 

b. Fill: Point or Area lights 

i. Properties > Data (Light) > Cast Shadow = disabled 

ii. Properties > Object > Shading > Shadow Linking > New 

(1) Drag object(s) from Outliner into the new Collection 

(2) If checkbox is off, then the listed object will not cast a shadow from the 
selected light 

29. Environment lighting 

a. World Output node Surface input 

b. Flat color: Background node 

c. Color temperature: Blackbody node 

d. Properties > Render > Color Management > White Balance 

e. HDRI: Environment Texture node 

f. Sky Texture node 

30. Animation basics 

a. Properties > Output > Format > Frame rate 

b. Frame Range is the playback range 
Independent of Timeline range 

c. Timeline > Playback pulldown > Sync 

31. Insert Keyframe 

a. For clarity, display transforms first: Sidebar (N) > Item tab 
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b. Choose which channels / tracks to animate 

i. By default, all transform channels will be keyed 

ii. Timeline > Keying pulldown > Active Keying Set 

(1) Only works with interactive manipulation, not numeric entry 

c. Object > Animation > Insert Keyframe 
Shortcut: I 

i. Keyframes are inserted at current time, for current Active Keying Set, 
regardless of whether or not any channel value has updated 

ii. Even if only one axis is updated, all three axes are keyed 

iii. Insert Keyframe Menu shortcut: K 

d. If a channel is updated without inserting a key, then when the current time 
changes, the existing channel values are loaded  

i. If you forget to insert a key and then scrub timeline, you lose those changes 

ii. Undo won’t save you 

e. Channels can be manually keyed, ignoring Active Keying Set 

i. Numeric entry field of any transform or property 

(1) Green: at least one keyframe, at some time other than current 

(2) Orange: keyframe at the current time 

ii. Key all axes: right-click > Insert Keyframes 

iii. Key individual axes: right-click > Insert Single Keyframe 

iv. Key object properties: click dot to right of field, or hover mouse and press I 

32. Timeline 

a. Transport shortcuts 

i. Play/Pause: SPACE 

ii. Jump to First Frame: SHIFT + LEFTARROW 

iii. Jump to Last Frame: SHIFT + RIGHTARROW 
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iv. Jump to Previous/Next Keyframe: DOWNARROW / UPARROW 

b. Newly created keys are selected automatically, highlighted in orange 

c. Drag to move keys 

d. Summary track displays all keys for selected objects 

i. Open up Summary to access individual channels 

e. A bar between keyframes indicates a static value in that time range 

33. Auto Keyframe 

a. Enable with dot icon to the left of transport controls 

b. Interactive manipulation 

i.  Creates key(s) at current time 

ii. If no Active Keying Set is enabled, only the updated axes are keyed 

iii. If an Active Keying Set is enabled, all axes are keyed 

c. Numeric entry 

i. Only the updated axes are keyed  

ii. If no keys exist on a channel, numeric entry does not create keys 

iii. If keys do exist on a channel, numeric entry creates keys 

34. Dope Sheet 

a. Very similar to Timeline 

b. Filters 
Buttons on Dope Sheet header 

i. Only Show Selected 

c. Channels 

i. Not all rows are actual channels, e.g. top-level Object rows and Action rows 

ii. Action rows are containers for Object properties, e.g. Transforms 

iii. Individual transform axis rows are actual channels that can hold keyframes 
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(1) Object Transform rows are containers for individual transform channels 

(2) If an Object Transform row is collapsed, then Channel menu commands 
operate on all subordinate (hidden) channels 

iv. Delete static channels: Clean Channels 

35. Graph Editor 

a. Function curves 

i. Transform or property value is the vertical axis 

ii. Rate of change indicated by slope 

b. Selected keyframe values: Sidebar (N) > F-Curve tab 

c. Shortcuts 

i. Pan: middle mouse drag 

ii. Zoom: CTRL + middle mouse drag 

iii. Constrain to Time (preserve value): start moving a key or handle, then press 
X 

iv. Constrain to Value (preserve time): start moving a key or handle, then press 
Y 

d. Interpolation modes 

i. Linear 

ii. Constant also known as step or hold keys 

iii. Bezier Handle Type 

(1) Automatic 

(2) Automatic Clamped: prevent overshooting 

(3) Aligned: lock angles (move together) 

(4) Free: unlock angles (move separately) 

(5) Vector: linear (handles point to neighboring keyframes) 

iv. No way to lock incoming and outgoing handle lengths together 
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(1) Select a single keyframe 

(2) Graph Editor menu > Key > Snap > Equalize Handles 

(3) Scale the key  

36. Outliner 

a. Default mode: View Layer 

i. Display layers and scene hierarchy combined in one window; unorthodox 

ii. On rare occasions you may need to use Scenes or Blender File mode 

b. Filters > Selectable 

c. Collections 

i. All objects must be members of at least one Collection 

ii. If an object is Removed or Unlinked from all Collections, it is “orphan data” 
with “zero users” and gets automatically deleted when the scene is saved 

iii. Objects can be members of more than one Collection at a time 

iv. Collection membership is not inherited from parent 

v. Right-click > Select Hierarchy 

vi. Drag and drop 

vii. Move to Collection 

(1) Shortcut: M 

viii. Link to Collection (instance object in multiple Collections) 
Shortcut: SHIFT + M 

ix. Remove from Collection 
Shortcut: CTRL + ALT + G 

37. Coordinate systems 

a. Transformation Orientation pulldown 

i. Temporary frame of reference for transforms 

ii. Not a property of the object, but the behavior of the Gizmo 
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b. Global: relative to world/scene  

c. Local: relative to object Origin 

d. View: screen space 

e. Parent: relative to object parent 

i. All transforms are actually calculated relative to the object parent 

ii. Parent orientation sets the temporary frame of reference to the true coordinate 
space of object transforms 

iii. If the object has no parent, then the global world/scene is the parent 

f. Gimbal: low-level visualization for rotations 

i. Gizmo displays the interaction of rotation axes relative to one another 

ii. Avoids problems such as rotations getting stuck or animating out of control 

g. Normal: relative to  average orientation of selected faces 

h. Custom 

i. Select an object or component 

ii. Transformation Orientation pulldown > click plus sign icon 

38. Transform Pivot Point 

a. Determines the temporary location of the Object Gizmo 

b. Temporary center for rotation and scale operations 

c. Rotate and scale around average position of object Origins: Median Point 

d. Rotate and scale each object separately: Individual Origins 

39. Origins 

a. Also known as pivot point or anchor point in other programs, but in Blender the 
Pivot Point is the location of the Object Gizmo 

b. Origin is the center of object transforms; values displayed are those of the 
selected object’s Origin 

c. Origin position and orientation are critical for animated rotations 
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d. Must be finalized before creating keyframes 

e. Sidebar (N) > Tool tab > Options > Transform > Affect Only > Origins 

40. Hierarchies 

a. Chain of linked objects; articulated structure such as skeleton 

b. Children inherit transforms from their parents 

c. An object may have many children, but only one parent 

d. Any object can be linked: geometry, lights, cameras, etc. 

e. Scaling in hierarchies can cause problems. Keep all object Scale values at 1.0 

f. Object > Apply > Scale 
Shortcut: CTRL + A 

g. Empty object:  a visible but non-rendering transform node for building 
hierarchies and rigs 

i. Also known in other programs as dummy, locator, helper, point 

41. Parenting / linking 

a. Blender is unconventional and problematic without specific intervention 

i. In reality, transforms are calculated relative to object parent 

ii. Problem: Blender obscures this by displaying values with an offset 

iii. Child object transforms are displayed in Global coordinates, but this is not 
how child transforms work! 

b. To make Blender display child transforms correctly: 

i. Select desired child(ren), SHIFT+select desired parent (makes it Active) 

ii. Object > Parent > Make Parent without Inverse (Keep Transform) 

iii. Shortcut: CTRL + P 
Then in popup menu: Object (Keep Transform Without Inverse) 

c. To unparent (break link): 

i. Select child 
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ii. Object > Parent > Clear and Keep Transformation 

iii. Shortcut: ALT + P 
Then in popup menu: Clear and Keep Transformation 

42. Constraints 

a. Properties > Constraints tab 

b. A constraint applied to an object (“owner”) will override its transforms 

i. Combine effects using Empty objects / Parents and/or Constraints 

c. A Constraint also requires a target 

d. “Look at” constraint: Track To 

43. Drivers 

a. Connect transforms and/or properties to one another 

i. Optionally use scripted math expressions 

b. Simple workflow 

i. Right-click a property or transform, choose Copy As New Driver 

ii. Right-click some other property or transform, choose Paste Driver 

c. Wheel on the ground: Z position = radius 

d. Wheel turning: Z rotation = -Y position/radius 

44. Geometry Nodes 

a. Start with a mesh object 

b. Geometry Nodes tab > Geometry Node Editor  > click New 

i. Geometry Nodes Modifier added 

c. Pin the Editor to keep graph visible regardless of current object selection 

d. Drag objects from Outliner into Editor 

e. Add nodes shortcut: SHIFT + A 

f. I/O ports with long strips instead of dots accept multiple inputs 




